Huanter

Problem on Legacy Air Con

11 posts in this topic

Hi,

 

I had an issue on my air con. Air con having hot air coming out after not long gas top up. Any recommended place to do a repair? Roughly about how much?

Share this post


Link to post
Share on other sites

new LGT owner here... anyone encountered their aircon at times, auto switching from 're-circulating' mode to 'fresh air' mode when driving on road?

Share this post


Link to post
Share on other sites

Hey Snope, all you need to do when you set it to auto, cycle once thru the modes. If you turn on using the "auto" fucntion, its full auto, whereas if you cycle thru, only the fan speed is on auto

Share this post


Link to post
Share on other sites

thanks pal, but never like setting mine to auto...

 

whenever I start my car, I always turn on the A/C using the up arrow(fan speed) button and by default, it will be on 're-circulating' mode. But always after driving for some distance, it will turn to 'fresh air' mode which I have to switch it back manually.

Share this post


Link to post
Share on other sites

It is normal for it to switch to fresh air mode once it detects that your cabin temperature has reached your set temperature. Apparently this is some safety feature to bring in fresh air according to over overseas forum I've read. 

Share this post


Link to post
Share on other sites

set the air con temp below 21deg.

 

if 21deg n abv, it will auto open circ outside air

Share this post


Link to post
Share on other sites

The air con is very problematic indeed. I have been breathing in carbon monoxide. I have a way to override this auto switch problem. But very time you start engine you have to do this step (very fustrating but no choice). 

Press 'Auto' to on

Press 'mode' 3 times

Press 'A/C' 2 times

Press 'the car symbol below A/C' 1 time

Press 'mode' 1 time. 

This will override the auto switch of outside air coming in. After doing this you can do any tempereature & fun adjusment and the outside air will not come in. But need to do everytime you start engine. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now